Main Content

Technical Requirements

Tech Requirements

 

Listed below are the supported operating systems and browsers for use with the Blackboard Academic Suite. The Academic Suite is a Web-based application. Other browsers and operating systems may work well, however, the listed configurations are the only configurations that are tested and supported by Blackboard.

Useful Information
USEFUL INFORMATION

All configurations marked as Compatible have undergone a limited engineering analysis to test areas of the Blackboard Academic Suite that may have browser issues.
 
Computer & Technical Requirements for LPN-RN Online Program
Certified: fully tested and supported.
Compatible: partially tested but should function properly.
Provisional: future technologies considered supported by Blackboard Support.
Unsupported: either impossible or not tested.
  

Microsoft® Windows® Operating System


Internet Explorer 8 Internet Explorer 7 Firefox_3.6
Firefox_3.5
XP (32-bit)
Compatible
Compatible
Compatible
Compatible
Vista (32-bit)
Certified
Compatible
Certified
Compatible
Vista (64-bit)
Compatible
Compatible
Compatible
Compatible
Windows 7 (32-bit)
Certified
Unsupported
Certified
Compatible
Windows 7 (64-bit)
Compatible
Unsupported
Compatible
Compatible

 

Apple® Mac OS® Operating System


Safari 5.0
Safari 4.0
Safari 3.2
Firefox 3.6
Firefox 3.5
OSX 10.5 "Leopard"
Provisional
Compatible
Compatible
Compatible
Compatible
OSX 10.6 "Snow Leopard"
Provisional
Certified
Unsupported
Certified
Compatible

 

  • Blackboard strives to make all its products as accessible as possible. JAWS for Windows 9 and 10 were used during accessibility testing.
  • Blackboard Learn requires the latest version of Sun JRE 6. The JRE can be downloaded from http://java.sun.com/javase/downloads/index.jsp.
  • deprecation
    • Internet Explorer 6
    • Firefox 1.x, 2.0, and 3.0
    • Safari 2.0
    • Mac OSX 10.4 "Tiger"
    • Java 5
  • Internet Explorer 8 is tested in Standards Mode. Some known issues can be resolved by using Compatibility Mode (emulates IE7 behavior).

 

Get Adobe reader   * Note: You need to have Adobe Reader installed to view and print PDF files.